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1 Introduction

1.1 Welcome

Welcome to RouteFinder, a network analysis system for Maplnfo Professional.

RouteFinder comes in 3 versions:

e Free - With reduced functionality which will allow the user to find the shortest or fastest path
and other basic functions on a network with a maximum of 3000 links

e Standard — With most functions available for the user with a need to perform route
calculations such as travelling salesman analysis, distance matrices, isochrones etc.

e Professional — With all the functionality of the standard version, but allowing larger datasets to
be processed. Included is a broad range of network topology checking functions.

The documentation is created so that the first chapter describes all the basic features available in
the free version. Then the additional features available in the standard version is described in the
next chapter etc.

© 2006 RouteWare and Higher Mapping Solutions
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1.2

Feature Matrix

Free / demo Standard Professional
Link limit 3,000 500,000 16 Million
Support of both lat/long and projected X X X
coordinates
Shortest / quickest[231 path - click X X X
Km or Miles as distance unit X X X
Creates topological networks directly X X X
from TAB files
One-way streets X X X
32 road classes X X X
Via points - click X X X
Dynamic Segmentation X X
Isochrones - link based/33) X X
Isochrones - polygon based|3h X X

Travelling Salesman/sé Algorithm -
Point and Click

Max 300 rows

Max 3000 rows

Select from gazetteer [461- i.e. towns -
Routing

X

X

Allow Travelling Salesman/43 by
selecting from gazetteer

X

X

Distance Matrix[+h

Max 300 rows

x

Batch Isochrones/4&

Max 300 centres

x

Multi center isochrones - link
based/3#

Max 300 centres

x

Closest Centrel3$)

Max 300 centres

Nearest N Centres/4#

Max 300 centres

Route Descriptions/23)

X

Update Point table[sh

X

Dynamic cut-offs[s$

Cul-de sac detection/e)

Parallel link detection[e#

Subnet detection|es

Join links[ 76y

Display Nodes /5%

Detect Close nodes /e

Node - Link Check/e8

Overpasses Check /6%

X X| X X| X| X| X| X| X| X| X| X| X
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1.4

System Requirements

RouteFinder for Maplinfo:
Requires Maplnfo 4.1.2 or greater to run.

Harddisk requirement
3 MB without sample data.
6 MB with sample data.

Operating System
The application has been tested on Windows 98 and Windows 2000 SP4 and Windows XP SP2

Access rights
The user needs to have read/write access rights to the folder with the TAB files used for routing.

Processor speed

Depending on the kind of tasks, you are F(%rforming with RouteFinder, a fast processor may be a
good idea. Especially large Batch Routel411 jobs requires some processing time, but also some of
the topology checking functions do.

RAM

Depending on the size of the street networks you are going to work with, you may need additional
RAM. As a rule of thumb each record in the street database requires 50 bytes of RAM. An
example: A street network with 1,000,000 links will need app. 50 MB RAM to store the network.

Doing voronoi based calculations may easily require 2-3 times more RAM than mentioned above.
This includes Closest Centre/s5] and Voronoi Drive Time / Distance/s1).

Installation Notes

Installation steps

You should install MapInfo before you install RouteFinder.

If a previous version of RouteFinder 2 has been installed, you can leave it in place. Just make sure
you install into different directories.

Now install RouteFinder by running the setup application.

After you have installed RouteFinder, open Maplinfo and you will see RouteFinder 3.30 listed on the
Tools > Tool Manager.

You are now ready to use RouteFinder.

License file

When running the standard or professional version of RouteFinder, you receive a personalized
license file from RouteWare. This should be stored in the same directory as where you have
installed RouteFinder. This is normally "c:\program files\routefinder3_mapinfo".

The license file MUST never be handed over to anyone else. It is for the owner only !

RouteFinder has to be restarted to acknowledge the presence of the license file, but you do not
need to install RouteFinder again or restart Maplinfo.

Installed files
RouteFinder.mbx: Main mapbasic application

rwnet.dll: Used by the mbx.
RouteFinder.chm: This document

© 2006 RouteWare and Higher Mapping Solutions
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1.5

1.6

1.7

mic_rf.ini: All string resources in RouteFinder, can be translated
routefinder.lic: License file - not in free version

defrf: Default ini file for RouteFinder settings

DAV, Aaroads, GISnet: 3 folders with sample data

Support

You get free support via e-mail during your evaluation period and a further 30 days of support from
the date of purchase.

If you require support after this period, contact us at routefinder-mapinfo@routeware.dk for details
of our additional support contracts.

Licence Agreement

RouteFinder 3 for MapInfo Professional
© 2001-2005 by RouteWare and Higher Mapping Solutions
All rights reserved

SOFTWARE LICENSE

A single user license permits the use of RouteFinder on a single computer. Multiple user licenses
will be subject to the terms and conditions granted in such license.

You may not translate, reverse engineer, decompile, disassemble, modify or patch the RouteFinder
executable files or documentation in any way.

You may not use the RW Net DLL outside of RouteFinder in any way.

LIMITED WARRANTY
RouteWare warrants that all disks provided are free from defects in material and workmanship,
assuming normal use, for a period of 90 days from the date of purchase.

RouteWare warrants that the program will perform in substantial compliance with the
documentation supplied with the software product. If a significant defect in the product is found, the
Purchaser may return the product for a refund. In no event will such a refund exceed the purchase
price of the product.

EXCEPT AS PROVIDED ABOVE, ROUTEWARE DISCLAIMS ALL WARRANTIES, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMMITED TO IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE, WITH RESPECT TO THE
PRODUCT. SHOULD THE PROGRAM PROVE DEFECTIVE, THE PURCHASER ASSUMES THE
RISK OF PAYING THE ENTIRE COST OF ALL NECESSARY SERVICING, REPAIR, OR
CORRECTION AND ANY INCIDENTAL OR CONSEQUENTIAL DAMAGES. IN NO EVENT WILL
ROUTEWARE BE LIABLE FOR ANY DAMAGES WHATSOEVER (INCLUDING WITHOUT
LIMITATION DAMAGES FOR LOSS OF BUSINESS PROFITS, BUSINESS INTERRUPTION,
LOSS OF BUSINESS INFORMATION AND THE LIKE) ARISING OUT OF THE USE OR THE
INABILITY TO USE THIS PRODUCT EVEN IF ROUTEWARE HAS BEEN ADVISED OF THE
POSSIBILITY OF SUCH DAMAGES.

Use of this product for any period of time constitutes your acceptance of this agreement and
subjects you to its contents.

SDK

RouteFinder is built on top of RW Net, which is available as a separate SDK (software
development kit). This allows for royalty free deployment in most scenarios. Please see
RouteWare website for details about RW Net.

© 2006 RouteWare and Higher Mapping Solutions



Introduction 9

1.8

New Features in Version 3

Here is a quick summary of the new exciting features in this latest version of RouteFinder:

Dynamic Segmentation 23]
Now the dynamic segmentation options can be used in Batch Route, Nearest N Centres and
Travelling Salesman optimizations.

Nearest N Centres |47
This function will find the nearest N number of points from a selected start point or points. A very
quick function that will use distance or time.

Multiple Speed Files |2
More than one speed file can be created, so that it is now very easy to switch between peak and off
peak road speed or even walking speeds!

Route Pairs/4)
This will use two tables and then generate a route from row 1 of first table to row 1 of the second
table and so on.

Smoothing Isochrone/st)
Although there are some limitations of this option, it can present some nicer looking isochrones
rather than the spiky polygons produced by previous versions of RouteFinder.

Extended Data Check/191
This will check for object errors at network creation time and then present a report on possible
errors with the network that may need further investigation.

Drive Time Accuracy Eiy
Drive Time polygons can now use dynamic node adding to produce even more accurate
isochrones.

Updating a Point File with Time and Distance/s?)
It is now very easy to attach a time and distance to a point data set. This might be used to see how
far pupils are from a school.

Unlimited Centres| 61
You are no longer limited to a number of points for most batch functions in the Professional
version. In the Standard version the limit has been raised for most functions.

Professional Version only:

Node-Link Check!es]
You can now check that the links break at the nodes to make a topological network.

Overpass Detection 691
This function will check for links that intersect each other without a node being present. This may
indicate errors in topology.

© 2006 RouteWare and Higher Mapping Solutions
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1.9 Upgrading from Version 2

When upgrading from version 2, you will need to recompile your street network since the binary file
format has been updated (or rather extended). This is due to new functionality in version 3.

If you try to open a version 2 network then you will receive the following warning:

This network was compiled for a previous wersion
x.,'_'/ of RouteFinder. Do wou want to recompile the
netwark for the new wersion?

“'as Mo

If you select "Yes" then the network creation will be started otherwise please select network >
Create Network from Table menu option.

Click herel15) on creating a network for more information.

It is possible that some errors may be encountered in the upgrade process. If this happens then
follow these steps:

1. Close RouteFinder and Maplnfo.
2. Manually delete the following files from the directory containing the road network

Attribute.bin
Coord.bin
Coord2.bin
Dist.bin
Link.bin
Node.bin
RouteFinder.ini

You can leave link.spd if it exists, but if you do delete it then you will need to set up your road
speeds again. The link.spd file will be updated to version 3 format after having been used.

3. Restart Mapinfo and then open the table and then recreate the network.

1.10 History

Version 3.41 20th September 2006
Bug fix to Route Pairs function

Version 3.4 15th August 2006

Support for multi modal networks

New routine for allocating points to the nearest link on the network
Distance matrix - generate routes option put back in

© 2006 RouteWare and Higher Mapping Solutions
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Bug fix to distance matrix (commas can now be in the ID field)

Bug fix to distance unit not being reported correctly in isochrone generation
Better descriptions on batch drive time option

Capita EMS functions improvement.

Version 3.32 10th January 2006
Bug fix for batch multi centre isochrones

Version 3.31 25th November 2005
Bug fixed in Nearest function

Version 3.3, 22nd October 2005
Route pairs routine speed enhancement
Interactve route added for the Capita EMS system

Version 3.2, 14th June 2005

New Capita EMS Link code added (you need a separate module to activate)

Bug fix to route pairs progress bar

Bug fix to Isochrone set up dialog

Bug fix to progress bar not activating when second network is used within the same session
Bug fix to menu not displaying properly in short distance mode

Bug Fix to matrix builder

Version 3.1, 8th Feb 2005

New function - Drive time from a column in a table.
Bug fix to Drive time options dialog

Bug fix to Road Speeds dialog

Bug fix to Route pairs function

Version 3.03, 4th Jan 2005
Bug fix to matrix builder

Version 3.02, 4-Dec-2004
Bug Fix to matrix builder
Fix to Batch TSP Function

Version 3.01, 4-Nov-2004
Minor bug fixes
Unofficial support for Z-levels. Ask RouteWare if you need information on how to use this.

Version 3.00, 5-Oct-2004:
Major release

Version 2.02, 3-Feb-2003:
Bug fix release (required new license file)

Version 2.01, 29-Nov-2002:
Bug fix release

Version 2.00, 12-Oct-2002:
Major release (free upgrade)

Version 1.02, 15-Jun-2001:
Bug fix release

Version 1.00, 5-Apr-2001:
First release

© 2006 RouteWare and Higher Mapping Solutions
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2
2.1

2.2

Basic Functions
Starting RouteFinder

From the Start Menus

1) Click on the start button

2) Navigate to Programs > RouteFinder

3) Select RouteFinder from the list of items

RouteFinder will start Maplnfo Professional and then start RouteFinder.

From within MapInfo

1) Select Run Mapbasic program from the file menu in Maplnfo Professional.
2) Navigate to the RouteFinder.mbx

3) Select the mbx and press OK

Using the Tool Manager

1) Navigate to Tools > Tool Manager

2) Scroll down the list until you find RouteFinder 3.00

3) Select Load and press OK

4) You can also check the autoload option and this will start RouteFinder every time Mapinfo is
started

The menu bar should now have an item called RouteFinder displayed and should look like the
screen below:

RouteFinder Help

Network »
= Options »
I Batch Functions 4

Analyze »

Clear RouteFinder Results

AboLt RouteFinder

Exit RouteFinder

Creating a Network

In order to create a network to use for routing with RouteFinder, these steps should have been
prepared first:

1) Input file

You need to have a TAB file, that can be either normal native format, DBF based, Access based or
a Maplnfo street table (linked). It should (mainly) contain polylines and must not be marked as
read-only or some F%erations will not be possible. You can read more about the topological
requirements here|791.

© 2006 RouteWare and Higher Mapping Solutions
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2) Road class
At least one integer field in the TAB file should be prepared for use as the road class field. Please
see below for a description of the road class attribute.

3) Street name

There doesn't have to be a street name field, but it is needed if you want to create driving
directions. The street name should of course be a string field, but you are free to choose a field
name. A secondary street name field can also be declared in case you have both street names and
route names. See Route Options% for detalils.

4) Result field

Some functions require that the results are written directly to a field in the attribute file. This field
has the name RF_RESULT and you should avoid having a field with the same name for a different
purpose. The field will be generated by RouteFinder when needed or you can add it yourself. It
should be of type decimal (11,3).

Road class attribute
This field will define the different classes of roads. The basic classes of road should be between 0
and 31. To define a one way street add 512. Add 1024 to create a one-way street that has been

digitised in the wrong direction.

Each road class from 0 to 31 can be assigned a different speed through the Road Speed%
options after the network has been created and loaded into RAM.

An example: If the first link in the network is a class 1 road (e.g. a motorway), which can only be
travelled in the direction of digitizing, the attribute will be 1 + 512 = 513.

If you don't have any information about road classes, just add an integer field with all zero's. This
means the same speed is used all over the network and all links can be travelled in both directions.

Actual creation of network
When the steps above has been taken care of, you are ready to create a network. From the

RouteFinder menu select the "Network" option and then "Create network from table" option. The
following dialog is displayed:

© 2006 RouteWare and Higher Mapping Solutions
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— Create Metwork From

towns
roads

selecttable to open

[T Extended Data Check

ik Cancel

Select the required table from the list displayed

If the table required is not currently open then use the open table button to select the required
table.

Extended Data Check
The extended data check/ 1) will check for the correct object types and for possible network
problems during the network creation routine.

You will be asked if you want to see this file once the process has completed.

A default speed file will be created if one has not been previously generated. You can use
RouteFinder > Preferences > Set Roads Speeds to adjust the required speeds for each class of
road. You can also create other speed files/2M to represent walking speeds, buses or any other
transportation mode.

If a network for the selected table already exists then you will be prompted to confirm overwriting of
the network files.

© 2006 RouteWare and Higher Mapping Solutions
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\Q) A network already exists - do wou want to owerarite
Lt it?

Yes o

When the user clicks on the OK button from the select table dialog, the user will be asked to select
the attribute column. This column should be defined as a numeric type in the table.

Select Attribute Column " il

Adtribute Column

I, Cancel |

Select the attribute column to use by selecting it from the drop down list. After pressing OK the
network is created on disk.

If for any reason the network fails to create using this method the user will be offered the option of
repeating the process using a MIF File export. In such a situation RouteWare will also like to have
a sample of the original TAB file for inspection and possible problem solving. You can email us at
routefinder-mapinfo@routeware.dk.

Finally you can choose to view the Network reportﬁsﬁ:

9 Do wouwant to see the network creation repor?

“es Mo

© 2006 RouteWare and Higher Mapping Solutions
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2.3

2.4

Opening a Network

If you have a table open that already has a network available when RouteFinder is started, then the
network files are automatically loaded.

If no network is open then you can load one by using the following instructions: -

1. From the RouteFinder menu, select the "Network" option and then "Open Road Network" option.

Open Network . x|
— Tahle to Open
ukroads
=electtable to open
4 Cancel

2. This will display a dialog, which lists the open tables. If you have no tables open the you can click
on "Select table to open" and choose an appropriate network table.

3. When you press OK the table on which the network is based on is opened (unless it is already
open). And then it is mapped or added to a currently open map window.

NB: If no network exists for this table then you will be given the option of creating one at this point.

Network Report

If you click on the Extended data check during the network creation process then the following
details are produced about you network. The report will be opened with your default text file editor:

Header detailing DLL version and the date the network creation was run

R I R I I I S O I I I I I I S I I I I S I R

Report for creation of network with RWNet 2.22
Internal version date: 10-SEP-2004

Today: 16-Sep-2004 21:01:03

R R R I I I S I I I R I I R I R

© 2006 RouteWare and Higher Mapping Solutions
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The coordinate unit of the table used to create the network
Coordinate unit: Latitude/Longitude

The next line reports if a zlevels.txt file was found and used in the creation process (if Zlevels.txt or
elevation.txt exists then Zlevels are uses)

You get a line similar to this if zlevels are being used

Using Z-1evel nodification:
C:\ Temp\ el evati on. t xt

and if the file is not found then you get

File for Z-level nodification not found:
C:\ Temp\ el evati on. t xt

The two files used to create the network are listed here
I nput files:

C. \ t enp\ AA\ AARoads. map
C.\tenp\ AA\ AARoads. i d

The coordinate system of the table used to create the network

Coor di nate system
CoordSys Earth Projection 1, 104

The next section details any problems found in the network during the creation process. This is
only problems for single records! Scroll down for all possible codes that can be found at this point.
If you have the professional version you can use the network analysis tools/s8] to identify and
correct problems involving more than one record at a time.

+++ Error-report +++

(6) Object 52249 has duplicate vertices (may nean self-intersecting)
(2) Object 364 is not a polyline - skipped

+++ Error-report +++

The maximum valency is reported and an explanation on what the network representation type.
Valency is the number of links at a node.

Maxi mum val ency: 5
Expl anation: Nornal detailed street data

The total length of all the streets and the average link length in the network
Total length of streets: 81896.7406220701 kn

Average per link: 0.267298353461701 kn
267.298353461701 neter

The number of links and nodes in the network

Li nks i n dat abase: 306387
Nodes created: 227152

The return code should be 0 if it was a successful creation

Return code: 0

© 2006 RouteWare and Higher Mapping Solutions
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Possible codes that could be found in the Error-report section

: Object is marked for deletion / not geocoded

: Object is not a polyline

: Object has >1 parts

: Object has zero length

: Object is a loop link

: Object has duplicate vertices (may mean self-intersecting)

: Object is self-intersecting

: Object has a very sharp turn (less than 45 degrees from a U-turn)
: Object has only 0 or 1 vertex

OCO~NOUIA,WNE

Route
N

Click to add starting point. The word "Start" will appear on the map.
Use the Ctrl-Click to add via's. The number of the via will then appear on the map.
Shift-Click to add the last point. The word "Finish" will appear on the map.

The route is then calculated and displayed on the map. Using the "Route Options%" on the
preferences menu item can change the style of the line used to display the route

The time and distance is displayed in the message window

An example route is shown below.

rd

Start

© 2006 RouteWare and Higher Mapping Solutions
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2.6

B

30.37 minutes Distance= 13.48 Mi

If you have turned on route descriptions%, you will also get a list generated, where you can click
on each part of the route description and see it highlighted on the map:

Start
Finish

EE RouteDirections Browser
Description Distance Time Direction
[ ]| Start along Unclassified Road for [ 0.5 Mi 1.51 mins Slight turn to right
B 2272 for 2.98 Mi B8.95 mins Turn Left
|:| Unclassified Road for 1.42 M 4.26 mins Stage
[ ]| Total Distance 4.91 M 14.72 mins | Finish

To create routes based on points already recorded in a table, refer to either Select Locations| 401 or
Batch Route|41]

Clear Result

o

This function will close all temporary results generated by RouteFinder (not just routes - also
isochrones etc.). Use it, when you want to start creating new routes as the normal mode keeps
adding generated routes to the previous ones.

You can also right click in the map window and select "Clear RouteFinder Results" as well as
selecting it from the RouteFinder menu
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2.7

Route Options
Go to RouteFinder > Options > Route Options.

The following dialog is displayed:

Route Options ﬂ

—Mode—— ~ FRoute Type

Route Dizplay Calculation Type * Mode 1 Y .
* MNode-to-Hode

(¥ Fastest " Mode 2
x  Mode 3 " Exact
" Shortest oiel=

 Mode 4 " Exact with OF Foad
™ Display Route Descriptions ¥ Usze one way I Mithr
IDireu:tiu:un Calurmm j Prirnary

IDireu:tiu:un Calurmn j 5 econdany Cancel |

The route display button will allow the user to select the line style used to display calculated routes
on the map.

Il Line Style . x|

otyle: | | ¥

Colar; I_li —Sample

Wi clth
" Pixels I |£
{ Points ||:|,2 LI

QI Cancel | Help

From here the user can choose the style, colour and thickness of the line used to display routes.
This dialog may vary from version to version of Maplnfo Professional

Shortest / Fastest

The calculation type will determine whether upon calculating a route, the shortest or fastest path is
generated. This also affects the Drive Time Polygons and all other calculations. In "Fastest" Mode
the polygons represent actual drive time, whilst in "Shortest" mode the polygons will represent
Drive Distances. The menus are changed to show which mode you are currently working in.

Mode Option

This will let you run the same network in different ways. For instance you may decide in mode 1 all
links are accessible, mode 2 might be Cars, mode 3 HGV and mode 4 for pedestrians. In order to
define this modes you would add the following values to the attribute value on a link.

Add 32 if mode 1 isn't allowed on this link.
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Add 64 if mode 2 isn't allowed on this link.
Add 128 if mode 3 isn't allowed on this link.
Add 256 if mode 4 isn't allowed on this link.

You can add your own desciption to each mode by editing the RouteFinder.ini and editing the
sections marked Model-4

Use One Way

With this option checked one way street restrictions are obeyed. When unchecked then the
network effectively becomes a walking network where you can go both ways on a one way street or
any direction around a roundabout.

Route Type
This is used to control the dynamic segmentation options. These are as follows:

Node-To-Node — This is the default setting. The route will start and end at the nearest node to
where the user clicks. A node is either a start- or end node of a polyline.

Finish

Exact (dynamic segmentation) — The route is calculated from the nearest part of a link from where
the user clicked. The resulting route will take into account the amount of time and distance to travel
the partial segment of the link.
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Finish
*

Start

Exact with Off road — This is the same as the above option except it will also add a link from the
point where the user clicked to the nearest part of the network. To use this option you will need to
put in an off road speed. This is used to estimate the amount of time it takes to get from the start
and end points to the network. The resulting route will take into account the amount of time and
distance to travel the partial segment of the link.

Finish

Start

Route Descriptions

The route descriptions are switched on or off from and the column(s) containing the relevant route
description is selected from the drop down list. You have the option of defining a primary and a
secondary direction field. This can typically be used this way:

Primary = Street name
Secondary = <none>
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or

Primary = Route hame
Secondary = Street name

So, if the primary field is blank, the secondary will be used instead.

When a route or Travelling salesman has been generated a window will appear with the directions
and it will also be possible to click on each part of the route description and see it highlighted on
the map.

EE RouteDirections Browser

Description Distance Time Direction
[ ]| Start along Unclassified for 0.66 Mi 263 mins Turn Right
[ ]| 482 far 0.43 Mi 0.75 mins sharp Right
|:| M1 for 526 Mi 6.57 mins sharp Left
[ ]] 4453 for 416 M 10.6 mins Slight turn to Left
[ ]| Unclassified for 0.31 Mi 1.23 mins otage
|:| Total Distance 10.85 Mi 21.78 mins | Finish
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2.8

Road Speed Options

Go to RouteFinder > Options > Road Speeds

Road Speeds

—aelect 5peed File

link.=spd

Save as.. Delete |
—Amend Road Speeds
Current Road Speed
Class &
Class 3 |45
Class 4
Classh
@ Miperhour
" Km per hour
Add | Edit | Deleta |

Ok,

Cancel

The speeds for different classes of road are defined in the link.spd file that will be in the same
directory as the network files. This is a simple text file that can be edited, but care will be required

to do this.

Select Speed File

You can now have multiple speed files that hold different speed for the same network. This means
you can now have a speed file for peak, off peak even walking speeds. If you click on "Save as the

following dialog is displayed:

Save link.spd as...

|7Speed File Mame

Ok,

Cancel

Adding aroad class

When the user clicks on the "Add" button they will be prompted to enter the type of class (a number
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from 0 to 31) and a description for this class. This is shown below:

New Road Classification ; x|

Class Details

Twpe I Description

i Cancel |

Editing a description

Selecting the relevant item from the list and then clicking on the edit button can change the
description displayed in the list box. The user is then prompted for the new description.

Enter New Road Description ' : x|

Description

Ik Cancel

Deleting aroad class

Selecting the relevant item from the list and then clicking on the Delete button will remove that
class from the list box.

Changing the road speed

i) Selecting the relevant class from the list.
ii) Input the new speed in the "Current Road Speed".
iii) When you select another class the speed is updated

Distance measurements

The distances returned by the routing operations and the speed units are set by selecting either "Mi

per hour" or "Km per hour".
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3.1
3.1.1

Standard Version

Toolbar buttons

Drive Time (Voronoi)

L}

There are 2 methods available for doing drive time polygons (isochrones). This is the most
accurate of the 2, but also most demanding on processor time and RAM requirements. It is based

on creation of voronoi boundaries around network nodes.

To do a single isochrone you simply click on the map. To do more than one isochrone just hold the
“ctrl" key while clicking with the mouse button. To produce the isochrones hold the "shift" key down

while clicking for the last Isochrone.

You define the polygon setting through the Drive Time Options/st1 menu.

An example is shown below:
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3.1.2

s ol
Start Point /

Drive Time (Polygon)

(2

This is the fastest method for doing drive time polygons and less demanding on processing power.
The drawback is it doesn't produce as accurate results as method 132 and it can't create a single
output layer for multiple centers.

To do a single isochrone you simply click on the map. To do more than one isochrone just hold the
“ctrl" key while clicking with the mouse button. To produce the isochrones hold the "shift" key down
while clicking for the last isochrone.

You define the polygon setting through the Drive Time OptionsEﬁ menu, where the spikyness of
the isochrones can also be changed.

An example is shown below:
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3.1.3 Link Isochrone

pad

This function will create a new table, that shows drive times or drive distances from a point on the
map.

After selecting this tool you need to click on the map that represents the start location.

Link based isochrones always has their origin at a node, but the actual drive-time steps are using
dynamic segmentation.

An example link isochrone is shown below:
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The result will be stored in a layer called "IsoLink"

3.1.4 Multi Centre Link Isochrone

This is the same function as Link IsoChrone 33! except it can handle multiple centres at a time:
Click to add starting point.
Ctrl-Click to add more points.

Shift-Click to add the last point.

An example of this is shown below:
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3.1.5

Al
e

Closest Centre

K’
P

This function can be used to show polygons representing the parts of the road network that is
closest to a number of designated outlets (aka. service areas). It can be used as a first pass
territory planning system.

Click to add starting point. A small diamond represents the point. If the cIippingEﬁ options have
been set then this layer will also be clipped using the selected layer.

Use the Ctrl-Click to add more points

Then Shift-Click to add the last point.
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3.1.6

The result will be stored in a layer called "Closest"

Travelling Salesman

T

This function will show the optimised route between a series of points. For different modes of
operations, see herels41.

The points are entered interactively in the same way as in function Route/21).

Click to add starting point. Use the Ctrl-Click to add more points.

The word "Start" will appear on the map. A small diamond represents the points.

Then Shift-Click to add the last point. Then the optimal route is calculated through all the points.
There may be errors if you select two points at the same location. We are looking to improve this in

future versions of RouteFinder.

The points are labelled to show the order in which to visit them.
An example of this is shown below.
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3.1.7

B G

Cad 3

Update Point File

This function can be used to perform a quick update a point table with distances and times to a
point on a map.

After selecting this tool you need to click on the map that represents the start location.

The following dialog is displayed showing all the open tables:

Table to update

select point tahle

Ik, Cancel

From the drop down box select the tables that you want to add the time and distance.
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3.1.8

Once the process is completed the table will have RF_Time and RF_Dist added.

|Name Latitude Longitude RF TIME RF_DIST
[ ]| Haslemere 051 05 17 930 000 42 39 94 282 15.3
[ ]| Hindhead 051 05 459 350 000 43 5043w 21.07 1368
| Liphook 051 04 37 280 000 47 &7 67y 17.75 10.01
[ ]| Bardon 051 06 44 21M 000 51 1241 20.83 10.21
L |selborne 051 05 S0 850 000 56 27 90w 26,35 11.66
[ 1| East Lavant 050 52 05 44k 000 46 23 98y 47 11 21.22
[ ]| Waterbeach  |050 51 59.98M 000 43 54,17 43 21.52
[1|Beptan 050 57 30,260 000 45 25 57w 2361 12,93
[ ]| Cocking 050 56 55 03k 000 45 02 .00 26.1 1422
[]|East Dean 050 54 24 05K 000 42 53 920 |y 18.42
| Singletan 050 54 41 51 000 44 55 944 34 16.85
[ ]| Midhorst 050 59 03.77M 000 44 2007 18.67 11.74
[ ]| Easebourne 051 00 00 490 000 42 565 44w 2031 1275

IsoGrid

This will work in the Node to Node and Exact modes.

This option will create a grid-based isochrone.
Click to add starting point. The number of the point will appear on the map.
Use the Ctrl-Click to add more points. The number of the point will appear on the map.

Then Shift-Click to add the last point. The number of the point will appear on the map. The
following dialog appears: -

Enter Grid Size x|

Shade by
b |ﬁ [anid Size: 1850
- ¥ Cost
b ake 5 ko &
’ IT ake l:ILvIE-IfEEI  Node
Recale Grid |

(] LCancel |

By default parameters are calculated to display a square grid cells.

The number of grid cells is displayed to guide the user on how long it might take to generate the
grid. The higher the number the longer it will take.
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You can change the number of cells by typing in the X and Y boxes. You can enter a new value in
X and then use the "Make square to X" option to automatically calculate the Y value to create
square grid cells.

Use the "Recalc Grid" option to work out the number of grid cells in the new grid.

There are two options available for shading. This is selected by RouteFinder > Options > Change
IsoGrid Shading.

Cost — this will use the time or the distance as the basis for the isochrone.
Node — this will use the distance as the basis for the isochrone.

An example of cost shading shown here:
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40
3.2 Batch Jobs
3.2.1 Travelling Salesman from table
Go to RouteFinder > Batch Functions > TSP From Table
Travelling Salesman il

melecttable

[~ Paints already optimised

Ok, Cancel

For this function the table selected is optimized and the result is displayed on the map. The order in
the table is used as the start and end points. See the explanation of the options in the Travelling
salesman|36] button option. If you select the "Points already optimised" option then a route will be
generated based on the order of the points in the table.
How to create a table suitable for TSP Batch
If you need to define your start and/or the end points then you should build a new table from the
one that you want to optimize. Here is one way in, which this could be achieved:

1. Select the point you want to start with from the map or from a browser.

2. Use File > Save Copy as.. and save the selection to a new table.

3. Open the new table.

4. Next Select all the records from the target table and use the shift key and click to de-select
the start and/ or end points.

5. Use Table > Append Rows to Table to add the selection to your new table.

6. Select the point you want to end with (if required) and use the Append Rows to table to
add to your new table. Save your new table and you are then ready to do the optimization
with the table you have built.

3.2.2 Select Locations

Go to RouteFinder > Select Locations

This function will allow the user to select the start location, any via's and the end destination point
from a gazetteer. This will allow users to specify London as a start point and Newcastle as the end
point. The system will then produce a route from one to the other.

The following dialog is displayed:
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3.2.3

Route By Names . x|

— Tahle Setup

Tahle IAARDads

Ll Lo

Column  |DESC

— Route Infarmation

[ Add

[elete

L

® Boute

(" Optimise

073 Cancel

Select the table from the drop down list.

Select the column that contains the identifiers (e.g. Town)

Type in the name of the first location.

Click on the "Add" Button. If the location is not found in the table then close matches are
displayed for the user to select from

The location is displayed in the list box.

Repeat steps 3-5 to add locations. At least two must be selected.

Select between generating a "Route" and/or optimizing the route between the selected points.
Click on the OK button and the locations are processed and displayed on the map.

If you add a location by mistake then you can select the location from the list box and then
press the Delete button.

PonNE

©Co~NoO

Distance Matrix
Go to RouteFinder > Batch Functions > Distance Matrix

This function will allow generation of a matrix showing time and distance between numbers of
points. For example, depots to outlets.

The following dialog is displayed:
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Distance Matrix El

— Distance Matrix Boute Setup

— From
Table  |AdRoads =
Calurmn IDESE j
—To

Table I.-i‘-.ﬂ-.FI oads

I
Colurmn I DESC j

v Build Foute Objects [Slower
[T Calculate Both ways

ok Cancel

1. Select the table from the drop down list in the "From" box
2. Select the column that contains the identifiers (e.g. Town)
3. Repeat the selections from the "To" box

If the tables are the same you will have the option of calculating the routes in both directions. i.e.
Townl to Town2 and Town2 to Townl

The default is to calculate in one direction only.

You can also decide to not build the mappable routes. This option runs more quickly and will create
a smaller route results table.

The results will look like this, but can also be shown on a map:
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EE RouteResults Browser

FromID TolD Time | Dist
1| AEERDEEN ABERYSTWYTH 103025 42997
1| ABERDEEN ALLOA 293 71 12238
1| ABERDEEN AMDOVER 123124 513.02
1| ABERDEEN AMTRIM FU2 24 268 43
1| ABERDEEN ARBROATH 116.06 4919
1| ABERDEEN ARMAGH 77055 124 4
1| ABERDEEN ASHFORD 130552 54413
1| ABERDEEN ASHINGTON 547 2 228
1| ABERDEEN ATHLOME 1117 B3 455 55
1| ABERDEEN AYR 427 55 175.28
1| ABERDEEN BALLYMENA 71565 2952
1| ABERDEEN BANEBRIDGE 74905 3121
1| ABERDEEN BANBURY 1062 65 44277
1| ABERDEEN BANGOR 958 07 209 2

The distance column will be in the currently selected distance unit, either miles or kilometers. The
time will always be returned in minutes.

Route Directions cannot be generated with this option.

3.2.4 Route Pairs
Go to RouteFinder > Batch Functions > Route Pairs
This function will allow routes to be generated between two points in different tables. The number
of rows in each table must match for this function to work. When used the first row from table one

is selected as the start point and the first row in the second table is used as the end point.

When selected the following dialog is displayed:
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Batch Pairs Routes

— Distance katrix Foute Setup
—Fram
Takle ISampIe_Drigins LI
Column  |SAMPLENO ~|
—Tao
Takle
Calumn — |SaMPLENOD ~|
[ Build Route Ohjects (Slower)

ik Cancel

1. Select the first table from the drop down list in the "From" box
2. Select the column that contains the identifiers (e.g. Town)
3. Repeat the selections from the "To" box for the second table

The other option is to build map objects of each of the routes generated. If you use this option then

before the results are displayed you get the following question:

P Add routes to kdap?

“'ag Mo

By selecting "Yes" the routes will be added to the map.

The results will look like:
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B2 RouteResults Browser

From To Dist Time
(]| 10001 10007 0.130087 0.37341
[ ]| 10001 10007 0.130037 0.37341
(]| 10001 10007 366402 8.9281
[ 1| 10001 10007 3.63841 8.56663
[ ]| 10002 10002 0.961553 2.06368
(]| 10002 10002 0.404555 1.0272M1
(]| 10004 10004 1.26892 3.24118
(]| 10004 10004 0605705 1.66381
(]| 10004 10004 0.582533 1.60821
(]| 10004 10004 1.14913 2.95368
(]| 10004 10004 1.65202 417778

The distance column will be in the currently selected distance unit, either miles or kilometers. The
time will always be returned in minutes.

Route Directions cannot be generated with this option.
3.2.5 Allocate Point to Network
Go to RouteFinder > Batch Functions > Allocate point to network

This function will allow a point file to be allocated a link ID value or moved to the nearest link on the
network.
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Allocate Points bo Network x|

— Optionz
Puaint T able to uze

I ukroads j

[ Apply Rieference ta Paint table
Column ko Lpdate

o 2

Reference column fram Metwark,

Jio =

[ Check columnz against each ather
Check: thiz column fram the point table

Jio =
has the zame walue az thiz column from the netwark:

o ]

[ tove point ta nearest link

™ lgnore Points further away than

I Mi

Cancel |

The first option is to choose the Point table you want to allocate. Then you need to decide what
actions you want to do.

The first is to get the reference column from the road network table and put it into you point table.
eg a streetname.

Column to update

This is a column in your point table
Reference column

This is a column in the network table

You can validate the points so they are only updated if one column in the network table matches
that in the point table being used. Eg the street names have to be the same.

Check this column from the point table
Use this column in your point table as a reference to check the link in you network table

Has the same value as this column from the network table
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This is a column in your network table - it will be checked against the point being allocated. If the
refeences are the same the columns will be updated

Move Point to nearest link

By checking this option the point will be updated with the new coordinates of the nearest point on
the link.

Ignore points further away than
If the distance from the point to the nearest link is greater than the distance specified in the box
then it is ianored
3.2.6 Nearest N Centres
Go to RouteFinder > Batch Functions > Nearest N Centres
This function is useful for calculating the time and distance from a location until "Nearest" locations

on the list has been reached. It will work in Node-to-Node and exact mode the off road portion of
an exact route is ignored.

Select Parameters x|

— Origin / Destination Takle

Crigin Table

Itn:uwns LI

Origin D Column

IName LI

Diestination Takle

Itn:uwns LI

Destination 1D Column

IName LI

— Lirnits
Mumber of Tirme lirmit
MNearest 10 (mins) IE|
Centres
(0] Cancel |
Origin Table

Use the drop down boxes to select the table and the column to use as the identifier. The table
specified will be looped through one record at a time and used as the origin for the destinations.
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3.2.7

Destination Table
Use the drop down boxes to select the table and the column to use as the identifier. This is then
used by the function to get the nearest centres depending on the limits entered.

Number of Nearest Centres
If a number is entered in here then the function will find the nearest centres until this number is
reached. You cannot specify more centres than are in the destinations table.

Time Limit
If a number is entered into this box then it is used to find the nearest centres within the time
limitation.

You can combine the two limits together to say find the nearest 10 centres and within 20 minutes of
the origin. You should realise that this may return less centres than specified in the "Number of
Nearest Centres" box.

When the process has run you will get a table like this:

EE Nearest3 Browser
Origin Destination ID time [ Dist

[ ]| Mattingharn Mottingharm 1 0 0
[ ]| Mottingharn Derby 2 40,3817 16.5737
[] Mottingham Coalville 3 o483 271084
[ ]| Derby Derby 1 0 0
[ ]| Derby Mottingham 2 40,3817 16.5737
[ ]| Derby Coalville 3 53945 278917
|:| Coalville Coalville 1 1] 1]
[ ]| Coalille Leicester 2 25.7047 12 5195
L ]| Coalille Mottingharm 3 56.483 27.1084
|:| Leicester Leicester 1 1] 1]
[ ]| Leicester Coalville 2 25,7047 12 5195
[ ]| Leicester Hinckley 3 45 2232 16.58405
[ ]| Hinckley Hinckley 1 0 0
[ ]| Hinckley Rugby 2 365396 14 4157
[ ]| Hinckley Coventry 3 JB.5131 12.4kB52
[ ]| Coventry Coventry 1 0 0
L] Caventry Hinckley 2 36.8131 12,4652
[ ]| Coventry FRugby 3 45 5031 16.0561

Drive Times / Closest Centre
Go to RouteFinder > Batch Functions > Drive Times

This function will allow generation of multiple polygon or link based drive time or drive distance
polygons.

The following dialog is displayed:
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x

— Select Table andar Calumt

" Diive Time [Voronoi]

Ol
£ Diive Time [Polygon] ﬁr s
£ Link Drive Time

" Clozest Centre

ok I Cancel

The first step is to select a table of point objects from which to produce isochrones.
There are 4 options available in the Batch Drive Time (or drive distances).
The first option is to generate Voronoi st based isochrone polygons.

This next option is standard polygon isochrones. The style of these polygons is set using the Drive
Time|s2) (or Drive Distances@) option.

With the first two options you also have a choice of overlapping or non-overlapping polygons. If you
want the isochrones to overlap then you check the "overlap" box.

Here is an example of an overlapping isochrone:-

And in this example there is no shared area they are merged together.
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3.2.8

—

ISOCHRONE TOWN 1

-

Link drive time or distances will shade the links on the network according to the values set up in the
options dialog. These are non-overlapping by nature.

The last option in this dialog is to generate a map of closest center| s polygons. These are non-
overlapping by nature.

For the polygon options, you can also select a column name to work with the function. This will

then update the polygons that are created with the value of the selected field for each point. This
will allow you to easily identify which polygons have been created for each point on your map.

Drive Time from Column
Go to RouteFinder > Batch Functions > Drive Time From Column

This function will allow generation of multiple polygon or voronoi based isochrones that are based
on a distance or time for each point. The time or distance is set in a cloumn in a table.

The following dialog is displayed:
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3.3
3.3.1

Drive times from Table x|

T [ - |

|0 Colurmr INamE j
Dhgtance
Calumn I':':'St j
{* Polygon
ok Cancel |
= “aronoi

1) Select a table from the "Table" drop down menu of point objects from which to produce
isochrones.

2) Select a column from the "ID Column" to use to Identify each isochrone generated.
3) Select a numeric column which contains the required drive time or distance for the isochrone.

N.B if no numeric columns are in the selected table then the OK button will be greyed out and you
will not be able to continue the process

Options
Drive Time Options

Go to RouteFinder > Options > Drive Time or Drive Distance

The following dialog is displayed which allows you to add, delete or amend the number of zones or
the way they look.
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x
— Drive Time Properties
Zore 1 Add Zone |
Zone 2
Zone 3 Delete Zane |
2 mirs
¥ Doughnut Polygons [ Smooth lsochrones
Accuracy
-
[ Clip Polygon lzochiones el
i Average
ukroads -
I J % |Least
™ Custom I
ok Cancel |

The dialog shows a list of zone's added for generation of isochrones. The values reflect either
distance or time depending on the choice of shortest or fastest route. Default values are 3 zones
with values of 5, 10 and 15.

Adding a Zone
When you click on the "Add Zone" button a new one is added to the list. It will always be one
greater than the last zone shown in the list.

Deleting a Zone
When the user clicks on the "Delete Zone" button the last zone displayed in the list is removed.

Changing a Zone Border Colour

To use this option you must first select a zone from the list displayed.

By clicking on the button with the line, the user will be able to select a line style in which the border
of the selected zone will be displayed.

Changing a Zone Fill Pattern

To use this option you must first select a zone from the list displayed.

By clicking on the button next to the line style button the user will be able to select a fill pattern for
the selected zone.

You can have separate styles and values for Drive Time and Drive Distances.

Doughnut polygons

When this option is checked then the overlaying polygons are cut from larger polygons. This results
in polygons that represent "bands" of time between two values, i.e: 0-5, 5-10 and 10-15. Otherwise
0-5, 0-10 and 0-15 polygons are generated.

Smooth Isochrones

This option will remove a lot of the spikyness of the voronoi ands polygon isochrones to give them
a more rounded look and feel. This do slightly reduce the overall accuracy of the resulting
polygons. Also there are some circumstances when using the voronoi type polygons that gaps may
appear between polygon vertices. It is up to the user to decide when to use them and when it is
inappropriate to use them. Closest centre polygons are not smoothed.
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Normal / Smoothed Isochrone

Accuracy
The accuracy option will determine how the drive time boundaries and closest centre polygons are
created. The same settings are used for both method 1321 & method I1/25) and is explained here.

Drive time (I)Eﬁ / Closest Centre[ss!:

During calculations additional nodes can be added dynamically along the links, so long links will get
more nodes added, while shorter links will not. You can define the approximate additional nodes to
have added compared to the initial number of nodes:

Most: 6 times more nodes.

Average: 3 times more nodes.

Least: No additional nodes (default).

Custom: Enter a number corresponding to the number of additional nodes you want (in the same
way as above).

The larger the number, the more RAM is needed and the requirements increases fast, so don't just
type in a large number.

Drive time (II)@:

Most — The isochrone will reflect very accurately the extents of the boundaries using every link in
the network. This results in very jagged looking boundaries.

Average — This will generalize some of the spikes to produce a smoother looking polygon.

Least - This will generalize some of the spikes to produce a much smoother looking polygon.
Custom - This is automatically set to be the most accurate isochrones possible. The additional
nodes do not affect this function in any other way

Clip Polygons
This allows the clipping of polygons to another table, for instance a coastline, and will give a nicer
presentation of the result. See the images below to see the difference in the options.
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3.3.2

Closest centres with polygons not clipped / clipped to the coastline.
This setting applies to Drive Time Polygons and Closest Centres.
Travelling Salesman Options

Go to RouteFinder > Option > TSP Options

RouteFinder has a number of options for the Travelling Salesman routine:
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TSP Options 3 x|

& Found Trip
(™ Star-End Point
(™ Start Point anly

(" Choose Everdime

[T Use Straight Line

0]3 Cancel

Round Trip — This is the default option. The route will Start and finish at the first point you click on
the map / found in your table.

Start-End Point — The route will start at the first point and finish at the last point. The order of the
points in between are optimised.

Start-Point only — The Route will start at the first point and the order of the rest of the points are
optimised. You will typically end at a point far away from the start point with this option (but not
always).

Choose Every time — This dialog is presented after a shift click so that you can select which
option you would like to run.

Use Straight Line — This can be a good option to use if you have a lot of points to optimise as it
will run faster, but the result may not be optimal since straight line distances are used in the
optimization instead of street distances.
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4
4.1

4.2

4.2.1

Professional Version

Dynamic Cut offs

The professional version can make some changes to the network without having to recreate the
binary files.

When the professional version is being used the following buttons are displayed:

=

Add a stop to a link on the network. Click to add the stop. Click again to remove the link. This
symbol will be added to the map to represent the link, which has been closed.

25

Allow a link to have its default road speed to be changed. This may be useful when road works
may be on a particular link on the network. This symbol will represent the link on which the speed
has been changed.

These changes are stored in a separate txt file (stops.) along with the street network.

Network Analysis

Included in the professional version of RouteFinder is a number of functions that allow the network
to be analyzed for topology and connectivity. It can also assist in removing nodes or links to make
the network more compact and therefore faster in generating routes or isochrones.

Several functions rely on creating small buffers for locating the problems. Therefore we
recommend that you avoid having street sections shorter than the size of these buffers or the result
of the analysis gets distorted. This is especially true for the Close Nodes|sd] and the Node-Link
check/ed] functions.

Add Node Layer
RouteFinder > Analyze > Add Node Layer

When you use this function you will get a new table added to your map window. The layer shows
the nodes that are used as a part of the network. It may assist you while you are working with the
network functions.

The node layer has these attributes: The internal ID (1, 2, 3 .....) and the valency. Valency is a
number >=1 and denotes the number of links attached to the node. You will normally find that most
nodes has a valency of 1, 2, 3 and 4, but larger values are also possible. If used with thematic
mapping, you can use this to check if the structure of the map seems OK. An example of this is
shown below.

The 2 nodes with valency 1 is probably the result of missing snap in the network. You would have
to zoom closer to see this properly, but the 2 nodes should be visible even at the map below:
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4.2.2

«

Detect Close Nodes

RouteFinder > Analyze > Detect Close Nodes

In almost any digitized network you may be able to find 2 or more polylines, which should have
shapped but doesn't do. This causes breaks in the network and therefore routes not generated
correctly. The function for detecting such problems is a very powerful tool for anyone working with
street data, where the quality may not have been thoroughly checked.

When this option is selected the flowing dialog is displayed:

Enter distance for close nodes _ iI

Distance

Ik Cancel

Simply enter the maximum distance between nodes that you wish to identify. You should only use
rather small values or a very large table will be generated. Only pairs of nodes, that are not
connected by a link, will be identified.
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In this instance the results are two nodes that are close together and not actually connected.

This browser is displayed after the function has completed to help in detecting the close nodes.
You can select a record from this browser and then use Query > Find Selection to move to that
point on the map.

Oooooooooon

Dist

0.006557 56

0.0142272

0.0224375

0.0279319

0.0372773

0.057234

0082133

0.0553543

0.07 45651

0.0752752

0.0783946
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4.2.3

Detect Cul-De-Sac

RouteFinder > Analyze > Detect Cul-De-Sac

Identifies cul-de-sac or blind alleys, which are defined like this:

Position yourself in a node and drive in one direction using link A. If you can't get back to the same
node without using the same link A again, it is a cul-de-sac.

If you however can come back without making a U-turn, it is a bridge or isthmus in graph theory
terms: If the link was missing, the network would be split into 2 components or subnets.

The first step is to choose a column to identify the links in the browser. This is typically the street
name.

Reference Column

Colurmn

K,

Cancel

Once OK is pressed the network is analyzed and then the map is shaded. A browser is then

shown.

A map is shown below:
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The Map here shows all the available network types.

63

This browser is displayed after the function has completed to help in detecting the Cul-De-Sacs.
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EE CulDeSac Browser

VEJNAVN [RF_Result [ObjectLen(Object, "M
1| GRANNINGEN 4,000 0.00120295
(1| STENBUKKEN 1.000 0.00132776
| N@RREBJERG RUNDDEL 4,000 0.00134445
(1| FLINTEBJERGVAENGET 1.000 0.00136357
(1| EBLEHAVEN 1,000 0.00137969
| NERAPARKEN 3.000 0.00143549
(1] SKOVHAVEN 3,000 000144419
(1| EERGMANNSVE 4,000 0,001 44585
(1| HUMLEBMAENGET 1.000 000146683
| KOGTYEDH®E 4,000 000147536
| LILLEBAELTSVAENGET 4,000 0.00151861
1| ODINSVE 1.000 0.00152735
1| FASANYVE 4,000 0.00153314
1| HESBJERG SKOWWEJ 1.000 000153855
1| TERNEVE 1.000 0.00154171
(1] AVERNAKZVE. 1,000 0.00154829

You can select a record from this browser and then use Query > Find Selection to move to that
point on the map.

RF_Result contains the type of link found. The numbers represent.
1 = cul-de-sac

2 = loops

3 = bridge

4 = Minor net

Finally a legend is displayed to show how many links of each type were found.

Legend E
Cul De Sac Result

Cul De Sac (15638
Loap (433
== Eridge (1403
bdinor Met (16493

[ i i i

4.2.4 Detect Parallel
RouteFinder > Analyze > Detect Parallel
Identifies groups of links, which start and end at the same two nodes.

The first step is to choose a column to identify the links in the browser. This is typically the street
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name.

Reference Column
Colurmn

K,

Cancel

Once OK is pressed the network is analyzed and a browser is then shown.

A map is shown below:

EE ParallelLinks Browser
DESC | RF_Result

M| Unclassified Road -10.000
L | Unclassified Road 10.000
[ ]| A2a6 -11.000
[ ]| Unclassified Road 11.000

65

Here is an example of a parallel link. You can now decide if both links are needed. If they are the

same type and attribute, the longer one will always be ignored. However, it may be used in
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4.2.5

Dynamic Segmentation Mode.

Three parallel links would have the value 10 (the shortest) and -10 for the other two. The next
group of parallel links has value 11 /-11 and then 12 / -12 etc.

Detect Subnets
RouteFinder > Analyze > Detect Subnet

Detects which part of a network is a subnet. A subnet is defined as a part of the network that isn't
connected to the rest of the network. The main net is defined as the part of the network, where
node 1 is found. Node 1 is the one with the highest valency and if there are more than one of
these, it is the West-most.

The function runs and then this dialog is displayed. You can view each subnet by clicking on the
number in the list box and then pressing the "Show" Button.

Show Subnets E x|

| — Subnets Detectad

3(1 Links)
4(1 Links)

Show i

After Pressing "Ok" the Browser is displayed. This time RF_RESULT contains the number of the
subnet in which the link resides.
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EZ SubNetTab Browser

DESC |FCGDE |RF_ResuIt

[ ]| Unclassified Road 4 1.000
B | Unclassified Road 4 2.000
M| Unclassified Road 4 2.000
M| Unclassified Road 4 2.000
B | Unclassified Road 4 2.000
M| Unclassified Road 4 2.000
B | Unclassified Road 4 2.000
M| Unclassified Road 4 2.000
M| Unclassified Road 4 2.000
B | Unclassified Road 4 2.000
[ ]| Unclassified Road 4 3.000
[ ]| Azas 3 4,000

Below is a map that shows a subnet identified by the function.
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4.2.6

Node-Link Check
RouteFinder > Analyze > Node-Link Check

This function will check the number of links in a buffer around each node against the reported
valencyﬁﬁ from RW net. Where this does not match the node is reported.

On selecting this option the following dialog is displayed:

Enter Distance from : iI
Check within
I meter(s)
0] Cancel |

When the function is complete the following dialog will be displayed:

|HudEID |"-J’a|ency|LinkCuunt
[] 162 c 4
] BR9 2 3
[] 529 2 3
L] 1045 1 3

You will now have to examine these point and split the link at the node if necessary or perform
other editing that is needed to correct the problem.

Here is a map, that shows the type of error that might be found:

© 2006 RouteWare and Higher Mapping Solutions



Professional Version 69

4.2.7

/

You can see here that there is a link that does not break at a node junction.

This function may also identify non-polyline or multi-sectioned polylines if you have any such in
your TAB file.

Overpasses Check
RouteFinder > Analyze > Overpasses Check

This is used to check for links that do not break at intersections or what could also be just a bridge.
This may cause problems when generating routes or be deliberately.

At the end of the function the map will display the locations:
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The pushpin's are in a browser called "OverPasses".
4.2.8 Remove Pseudo Nodes
RouteFinder > Analyze > Remove Pseudo Nodes
This function locates which links in a network can be joined together. If a node has only two links
connected to it, that node may be superfluous for some purposes (aka. a pseudo-node). For other

purposes it is needed, e.g. if you want to calculate the distance from that node to another or some
attribute value changes.

The first step is to choose a column to identify the links in the browser. This is typically the street
name.

Reference Column X |
Calumn

0] 4 Cancel
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Next you are asked if you want to make a back up of the network first. This is strongly

recommended, especially if you are going to change the links in your network. The following dialog
is displayed.

This function may update wour road netwark.

. Choose Na if wou want ta manually make a
backup first
es Mo

Now you are asked to input the distance at which nodes should be checked. If a network has many
very short links, which you would like to join, you can specify that links should be joined until they
reach a length of max length. If max length = 0, there is no upper limit and all links between nodes
with more or less than 2 links, will be connected.

Enter Link Limit {length) miles E _ il

Length

g

08

Next you are asked if you want to specify a column as a second check before links are joined. You
would use this to only join links of the same street name.

9 Do wouwantto use a column as join delimiter
\QJ (usually the streetnarme)?

“'as o

Next you will be asked if you want RouteFinder to perform the join of links automatically.
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Do wou want RouteFinder to perform the actual

- combine of elements [ves) or doyou want to do it
yourself (Ma)
'es Mo

If you want to do the join yourself then you will normally do it with MapInfo's Combine command, as
this gives control to how attributes are treated.

Finally a browser is displayed showing groups of links ready for joining:

VEJNAVN | RF_Result
[ ]|HESSGADE 1.000
[ ]|HESSGADE 1.000
[ ]|FEREVE.] 2.000
| FAEREWE. 2.000
L | Ly EvENGET 3.000
| Ly EnENGET 3.000
L ]| STRANDSTIEN 4.000
[ ]| STRANDPORTEN £.000
[ ]| STRANDPORTEN £.000
[ ]| EKSTRA YEJKODE 2999 10.000
[ ]|DYREDVE] 10.000
]| EKSTRA YEJKODE 9999 11.000
[ ]|DYREDVED 11.000
LMy YESTERGADE 12.000
C WY VESTERGADE 12.000

429 Show Unused Links

RouteFinder > Analyze > Show Unused Links

This function returns the number of unused links in the network. An unused link is one that isn't
part of any route at all. This is determined using the current speed setting (Shortest or Fastest) in
the route options dialog.

The first step is to choose a column to identify the links in the browser. This is typically the street
name.
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Reference Column X |
Column

0] Cancel

This map is displayed with the result of the function:

Here this link will never be used when the fastest route is selected. You can decide to remove this
link. However, it can be used in Dynamic Segmentation Mode.

After pressing "Ok" the browser is displayed.
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OOO00O0O00000 M

|DESC RF_Result

Unclassified Road 1.000
Unclassified Road 1.000
Unclassified Road 1.000
Unclassified Hoad 1.000
Unclassified Road 1.000
Unclassified Road 1.000
Unclassified Road 1.000
Unclassified Road 1.000
Unclassified Road 1.000
Unclassified Road 1.000

Py
T

—Result contains the type of link found.
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5 Street databases
5.1 Sample Data

RouteFinder comes with 3 datasets, which can be used for input for testing the functions:

GlISnet (UK + Ireland)

5= towns,ukroads,coastline Map

This data is kindly supplied by and is the copyright of Graphical Data Capture Ltd

Note: This sample dataset has more than 3000 links, so in order to try it in the free version, you will
have to delete some parts first.

AA road (UK small sample)
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i pagaz,AARoads Map

This data is kindly supplied by Kingswood MapMechanics and is the copyright of Automobile Association

DAV (Denmark, sample)
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5.2

& towns,roads,coas

This data is kindly supplied by COWI and is the copyright of DAV organization
Your Own Data

The quality of the data you will be using for street network calculations is very important. Many
street maps looks nice, when printed or viewed in a mapping application, but unless you check out
the details there may be problems.

How should your own street data look like, in order to be used in RouteFinder? The short answer
is they should snap and split at intersections and the network should be plane unless there
is an overpass.

Below is shown some examples on street networks, which are NOT correct, but all look correct
unless you check out the details:

Example 1: Missing snap at an intersection
This means the network doesn't connect and the movement to / from the disconnected section,
isn't possible. In the example below, the gap is just 1 meter and can't be seen at normal zoom
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levels.

Example 2: Split at overpass / underpass
This means a lot of impossible turn movements are suddenly made possible. This is a typical
roblem with TIGER data.

Example 3: Doesn't split/break at intersections
This means turns are not possible at most intersections.

Example 4: Double digitization with two street names, here name + route number
Not a really big problem, but the result of a route calculation may include one of the two streets in a
more or less random fashion.
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W 120th Ave

Example 5: Multi sectioned Polylines

Polylines with more than 1 section are ignored. They will not be part of any route.
A
£
£

When it comes to attribute data, there are actually no requirements at all, but you can read more
about it in the section about network creation|151.

53 Commercial Databases

RouteWare maintains a list on our website with commercial street database vendors.
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6

Troubleshooting

RouteFinder appears to crash on batch operations
This is usually because the tables selected for batch operations has deleted rows in it or
ungeocoded records. Please pack the table and try again.

If the problem persists please contact RouteWare or your local reseller.

RouteFinder produces a —30 error on network creation
There can be a number of reasons for this error to appear. The first thing to check is the range of
attributes used to classify the network. You can find more details herel1s] on valid ranges.

RouteFinder will recognise most projections. However if an error occurs please try saving a copy of
you table in Latitude/Longitude and see if the network is created successfully. If so then please
send a sample of your original road network to RouteWare so it can be analyzed and added to our
list of supported projections.

RouteFinder produces strange routes or gives an error on a simple route
This would normally happen because the attribute indicating road speeds has exceeded 32. Please
check the network table and make sure the attributes are within the 0-31 range.
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